Gmail errors "Please turn on SMTP Authentication" and "Recipient not found"

Questions and discussion about web design, search engine optimisation and hosting
Santeri
Posts: 192
Joined: 2017-7-5 09:58

Gmail errors "Please turn on SMTP Authentication" and "Recipient not found"

Unread post by Santeri » 2019-12-11 09:07

I made a web app using internationalized domain name (IDN). The domain name is lisäämyyntiä.com which is in punycode format https://www.xn--lismyynti-x2aag.com/. When I send email to the IDN, Gmail is giving me error messages claiming that the receiving email server is misconfigured.
Message not delivered

Your message couldn't be delivered to test@lisäämyyntiä.com because the remote server is misconfigured. See the technical details below for more information.
Same errors happen with or without punycode. Here are the specific, likely bogus Gmail error messages:
550 5.1.1 <test@xn--lismyynti-x2aag.com> Recipient not found. <http://x.co/irbounce>
550 Please turn on SMTP Authentication in your mail client. mail-ot1-f47.google.com [209.85.210.47]:46638 is not permitted to relay through this server without authentication.
IDNs are messing up Gmail. Other email clients don't give errors when sending emails to punycoded IDN:s. Also the email server works fine and relays, bounces and accepts email from Gmail to all non-IDN-domain without any problems.
Image Image I reported this issue to Gmail, but as they don't have a proper error reporting tool, I don't really expect them to do anything to fix this.



Santeri
Posts: 192
Joined: 2017-7-5 09:58

Data Migration: Error (Retrying) Authentication failure. (18017)

Unread post by Santeri » 2020-9-26 18:43

I just tested the same issues with G Suite and it works a little bit better. It even has some kind of support so I was able to report them the following bugs I found unlike with Gmail:
  1. Catch-all email routing fails with IDNs.
  2. Emails sent to IDNs in Domain aliases reply from default email address although "Reply from the same address the message was sent to" is set.
  3. Data migration IMAP timeout from Gmail account is so short that transferring larger accounts interrupts tens of times with error "Error (Retrying) Authentication failure. (18017)" which is very time consuming and annoying. After 1 day the transfer has barely reached 50% and interrupted 8 times.
I would not hold my breath while waiting for fixes. It took over half an hour and a dozen emails and a screenshot to get the support person understand that I simply want to report bugs and I actually know what I am doing. Meanwhile, I am sorry to say that IDNs are not working perfectly with G Suite either.

Santeri
Posts: 192
Joined: 2017-7-5 09:58

Re: Data Migration: Error (Retrying) Authentication failure. (18017)

Unread post by Santeri » 2020-10-9 01:21

Santeri wrote:
2020-9-26 18:43
  1. Catch-all email routing fails with IDNs.
  2. Emails sent to IDNs in Domain aliases reply from default email address although "Reply from the same address the message was sent to" is set.
  3. Data migration IMAP timeout from Gmail account is so short that transferring larger accounts interrupts tens of times with error "Error (Retrying) Authentication failure. (18017)" which is very time consuming and annoying. After 1 day the transfer has barely reached 50% and interrupted 8 times.
Reporting those bugs was waste of time. Nothing has happened and their G Suite is as broken as before.
Image

Santeri
Posts: 192
Joined: 2017-7-5 09:58

Re: Gmail errors "Please turn on SMTP Authentication" and "Recipient not found"

Unread post by Santeri » 2020-10-11 01:54

Wasting time with Poople support is a great way to make time pass unless you have something more important to do. I tried to give them feedback:
Image But Poople Support survey had conveniently expired:
Your survey session has expired and you cannot continue taking the survey.
Smart. Make feedback form expire before customer could expect any results. This way Mr. "Mark" will not get bad feelings about failing a customer and wasting their time for nothing.

Post Reply