SOLVED: TLS Negotiation failed, the certificate doesn't match the host., code: 0

Questions and discussion about web design, search engine optimisation and hosting
hamidjj86@gmail.com

Unread post by hamidjj86@gmail.com » 2020-4-16 03:30

Thanx Man

I spent 4 hours discussing it with godaddy team and they kept comig up with stupid solutions everytime!!!!



mwasapik

Unread post by mwasapik » 2020-4-16 07:09

For my case, updating SSL certificate for "mail.mydomain.tld" solved the error.

My client came from another host, so after moving to our server they noticed that everything was fine except existing "SEND AS" or "ALIAS" features via gmail. Since the error "TLS Negotiation failed, the certificate doesn't match the host., code: 0" suggests something about certificates, I noticed that this account was using different certificates from the one running in my server, that being not enough - certificates for "mail.mydomain.tld" was not installed. So I delete the whole certificate and re-installed from my server, and made sure that "mail.mydeomain.tld" has certificate installed. Tested the alias setting and it worked flawlessly. Hope this might help.

Palaash

Unread post by Palaash » 2020-4-16 16:15

Dear Santori,

Thank you for sharing your solution. I tried your solution. However, now I am getting the following error "Oops, we weren't able to finish. Please verify that you have entered the exact settings provided by your other email service. Contact your other email administrator for further details."

Can you please advice on this?

Thank you!

Palaash

Unread post by Palaash » 2020-4-16 16:21

Santeri,

You Sir are a Genius! Thank you so very much!

Everyone what I was doing is pasting the entire link, you just need to post the details in between https:// and :2083/)

Guest

Unread post by Guest » 2020-4-16 17:25

I am happy that I found your post this really helped me resolved the issue.

Santeri
Posts: 319
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-16 17:28

Guest wrote:
2020-4-16 17:25
I am happy that I found your post this really helped me resolved the issue.
Happy to hear and help1 Feel free to share it with others so that they will find it, too.

Cheers,

Santeri

ekta

Unread post by ekta » 2020-4-16 18:02

How to do for Plesk shared hosting?
I am unable to change in it

Santeri
Posts: 319
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-16 18:15

ekta wrote:
2020-4-16 18:02
How to do for Plesk shared hosting?
I am unable to change in it
What web address do you use for logging into plesk? Is it something like this:
https://docs.plesk.com/en-US/onyx/quick-start-guide/getting-started-with-plesk/understanding-subscriptions.74372/ wrote: You can log in to Plesk by visiting the following URL:

Code: Select all

https://<Plesk server's address>:8443
If it looks something like that, try the <Plesk server's address> as your SMTP server host name in Gmail and see if that works.

danbo

Unread post by danbo » 2020-4-17 01:51

Santeri wrote:
2020-4-11 13:18
GoDaddy "award-winning support team" was again lying to me, so I wasted 24 hours by waiting their "solution" instead of finding the fix by myself right away. Anyway, I found a permanent solution for the issue. It is easy, free and does not involve GoDaddy which means it can be done right away instead of waiting forever for nothing to happen. Here are the steps for fixing Gmail on GoDaddy.
  1. Login to your GoDaddy account
  2. Select All Products and Services
  3. Click Manage in Web hosting section Image
  4. Click cPanel Admin Image
  5. Copy host name from cPanel URL (shared server host name is between https:// and :2083/) Image
  6. Paste the host name to Gmail settings Accounts and Import/Send mail as/edit info/SMTP Server and click Save Changes
Image What made the issue more complicated was that both gmail and GoDaddy are to be blamed. Gmail has changed how they check SSL certificates and GoDaddy support is exploiting the issue by trying to peddle useless products for their clueless customers. Please let me know if you are still having issues after applying my fix.
Image
Happy hacking,

Santeri
this one doesnt work to me.

danbo

Unread post by danbo » 2020-4-17 02:07

Santeri wrote:
2020-4-15 04:05
1dre203 wrote:
2020-4-15 02:20
Thank you so much, this is the most valuable information I have come across so far better than GoDaddy's service. Unfortunately for me, the problem does not seem to go away. I am getting this after following your steps "Authentication failed. Please check your username/password.
Server returned error: "DNS Error: 9952402 DNS type 'aaaa' lookup of https://sg2plcpnl0131.prod.sin2.secureserver.net:2083/ responded with code NXDOMAIN 9952402 DNS type 'a' lookup of https://sg2plcpnl0131.prod.sin2.secureserver.net:2083/ responded with code NXDOMAIN , code: 0"


Any help will be greatly appreciated thank you
You need to remove ":2083/" from your server address as I mention in my instructions. Try sg2plcpnl0131.prod.sin2.secureserver.net and it should work fine.

THANK YOU SO MUCH! YOU SAVE MYLIFE! I ALREADY FIXED MINE WITH 300+ EMAIL MY GOD!

Chancery

Unread post by Chancery » 2020-4-17 08:17

Owen wrote:
2020-4-15 04:14
Can confirm that this works for crazydomains as well.
Hey Owen - are you able to provide instructions to fix the TLS problem with Crazy Domains?

Ali

Unread post by Ali » 2020-4-18 14:54

You are star

CRT

Unread post by CRT » 2020-4-18 17:20

My domain is hosted by godaddy but email is not. This problem started today (18 Apr 2020) and I'm at wits end trying to figure out what to do. I don't even know who to call for support. My domain provider might simply say they have nothing to do with Gmail and google will not even listen. Folks please advise.

Santeri
Posts: 319
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-18 17:27

CRT wrote:
2020-4-18 17:20
My domain is hosted by godaddy but email is not. This problem started today (18 Apr 2020) and I'm at wits end trying to figure out what to do. I don't even know who to call for support. My domain provider might simply say they have nothing to do with Gmail and google will not even listen. Folks please advise.
Where is your email hosted?

What is you domain?

mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-18 19:15

my e-mail as alias working only as unsecure throught port 25.
I do not have godaddy account, how to solve it?
Thank you sooo much

mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-18 19:25

I have e-mail from telekom.mk
my e-mail ends @t.mk

guest

Unread post by guest » 2020-4-18 22:36

I have the same problem but I'm using Hostgator. And I'm not very computer literate when I have to go too deep.

Santeri
Posts: 319
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-19 03:03

mman wrote:
2020-4-18 19:25
I have e-mail from telekom.mk
my e-mail ends @t.mk
SSL certificates on their server appear to be misconfigured or missing:
https://www.sslshopper.com/ssl-checker.html#hostname=mail.mt.net.mk wrote:No SSL certificates were found on mail.mt.net.mk. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall.
If they ever get them fixed, you could try this as SMTP server:

Code: Select all

mail.mt.net.mk

Santeri
Posts: 319
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-19 03:07

guest wrote:
2020-4-18 22:36
I have the same problem but I'm using Hostgator. And I'm not very computer literate when I have to go too deep.
Did you try to follow my instructions? Hostgator is using cPanel just like GoDaddy.

What is your current smtp server name that is not working?

What is the address of your website?

mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-19 12:06

Santeri wrote:
2020-4-19 03:03
mman wrote:
2020-4-18 19:25
I have e-mail from telekom.mk
my e-mail ends @t.mk
SSL certificates on their server appear to be misconfigured or missing:
https://www.sslshopper.com/ssl-checker.html#hostname=mail.mt.net.mk wrote:No SSL certificates were found on mail.mt.net.mk. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall.
If they ever get them fixed, you could try this as SMTP server:

Code: Select all

mail.mt.net.mk
Thank you so much Santeri
I have tryed mail.mt.net.mk but it does not fix it, the only fix is to go with unseccured port 25