SOLVED: TLS Negotiation failed, the certificate doesn't match the host., code: 0

Questions and discussion about web design, search engine optimisation and hosting
Santeri
Posts: 310
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-19 12:11

mman wrote:
2020-4-19 12:06
Thank you so much Santeri
I have tryed mail.mt.net.mk but it does not fix it, the only fix is to go with unseccured port 25
You are welcome. You might want to contact their support and tell them to get a valid SSL certificate for their SMTP server. I believe it is just a matter of time before Gmail will start rejecting unsecured connections as well.



mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-19 12:42

Santeri wrote:
2020-4-19 12:11
mman wrote:
2020-4-19 12:06
Thank you so much Santeri
I have tryed mail.mt.net.mk but it does not fix it, the only fix is to go with unseccured port 25
You are welcome. You might want to contact their support and tell them to get a valid SSL certificate for their SMTP server. I believe it is just a matter of time before Gmail will start rejecting unsecured connections as well.
I did contact them and told them, hope they will fix it.
BTW maybe I did something wrong, I have put mail.mt.net.mk where the smtp settings was. Do I need to do more? Port 25 or something else?

Santeri
Posts: 310
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-19 13:24

mman wrote:
2020-4-19 12:42
I did contact them and told them, hope they will fix it.
BTW maybe I did something wrong, I have put mail.mt.net.mk where the smtp settings was. Do I need to do more? Port 25 or something else?
The golden rule in software engineering is that if it works, don't touch it. Does it work now?

mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-19 13:45

Santeri wrote:
2020-4-19 13:24
mman wrote:
2020-4-19 12:42
I did contact them and told them, hope they will fix it.
BTW maybe I did something wrong, I have put mail.mt.net.mk where the smtp settings was. Do I need to do more? Port 25 or something else?
The golden rule in software engineering is that if it works, don't touch it. Does it work now?
No, it does not work. I have made changes just in smtp settings, I'm asking maybe do I need to change more, because I did just that, just smtp?

Santeri
Posts: 310
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-19 13:53

mman wrote:
2020-4-19 13:45
No, it does not work. I have made changes just in smtp settings, I'm asking maybe do I need to change more, because I did just that, just smtp?
I think your only option is to try port 25 and select Unsecured connection. If it does not work, consider changing your email provider.

Generally speaking if an email provider is not able to get a working SSL certificate for their SMTP server, it is not really a good sign and I would find very hard to trust such organisation.

mman
Posts: 6
Joined: 2020-4-18 15:42

Unread post by mman » 2020-4-19 14:10

Santeri wrote:
2020-4-19 13:53
mman wrote:
2020-4-19 13:45
No, it does not work. I have made changes just in smtp settings, I'm asking maybe do I need to change more, because I did just that, just smtp?
I think your only option is to try port 25 and select Unsecured connection. If it does not work, consider changing your email provider.

Generally speaking if an email provider is not able to get a working SSL certificate for their SMTP server, it is not really a good sign and I would find very hard to trust such organisation.
That's way is working now. Thank you a lot. BTW this provider is Deutsche Telekom but in my country the famous T-Mobile.

Yaniv

Unread post by Yaniv » 2020-4-19 15:22

Thanks Santeri!!

rah5
Posts: 2
Joined: 2020-4-19 23:12

Unread post by rah5 » 2020-4-20 03:25

Has anyone got this to work with crazy domains.
looks like they use Dreamscape Networks

Any help would be much appreciated

Santeri
Posts: 310
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-20 03:49

rah5 wrote:
2020-4-20 03:25
Has anyone got this to work with crazy domains.
looks like they use Dreamscape Networks

Any help would be much appreciated
What is your domain name and current SMTP server name? Do you use cPanel to access your hosting? If you do, what is the URL to your cPanel?

rah5
Posts: 2
Joined: 2020-4-19 23:12

Unread post by rah5 » 2020-4-20 06:24

For all those that use crazy domains use

for the smtp use: cp-wc36.per01.ds.network

Randolph McAfee

Unread post by Randolph McAfee » 2020-4-20 20:24

Brilliant!

lookingouttosee

Unread post by lookingouttosee » 2020-4-21 09:27

I just got it working. The URL of my cPanel was not working, however, I clicked on webmail on my cPanel and copied that URL (mail.antagonist.nl) omitting the https etc and it worked!!!! Finally. This is our entire company email with 7 of using Gmail in this way so it's such a big deal we are back up and running. Thank you so much!

Guest

Unread post by Guest » 2020-4-21 11:11

Thank you for the great help. You saved my life

Chuy Ibarra

Unread post by Chuy Ibarra » 2020-4-21 23:04

Muchas gracias! Thank you very much! I solved it!

Guest

Unread post by Guest » 2020-4-22 06:25

Guest wrote:
2020-4-12 06:17
Same principle worked with a Crazy Domain url. Thanks for the pointer!
Thank you for your comment, I tried with Crazy Domain too and it seems to work! :)

Guest

Unread post by Guest » 2020-4-22 12:13

Solved! Thanks! Really helpful!

happy shopper

Unread post by happy shopper » 2020-4-26 11:28

I've been looking a solution for weeks. As soon as I saw yours, I had an 'aha moment' as I remember always using that server name in the past. Thank you :-)

EwanRobb

Unread post by EwanRobb » 2020-4-28 16:36

Nothing working for me :cry:

Santeri
Posts: 310
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-28 16:57

EwanRobb wrote:
2020-4-28 16:36
Nothing working for me :cry:
Oh, damn. What is your domain name?

What hosting company are you using?

What are your current Gmail settings?

EwanRobb

Unread post by EwanRobb » 2020-4-28 17:31

DadsonFire.club. On GoDaddy, has worked fine for years and stopped today! Godaddy don't have a clue about it.

mail.dadsonfire.club
Port 587 TLS