SOLVED: TLS Negotiation failed, the certificate doesn't match the host., code: 0

Questions and discussion about web design, search engine optimisation and hosting
Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-10 13:14

Gmail has just stopped working with some GoDaddy hosting accounts.
Image This happens, when you try to connect to your SMTP server. When sending email, you will get the following error message:
You're sending this from a different address or alias using the 'Send mail as' feature. The settings for your 'Send mail as' account are misconfigured or out of date. Check those settings and try resending.

The response was:

TLS Negotiation failed, the certificate doesn't match the host.
If you edit your Send mail as settings, you will get the following error message:
Authentication failed. Please check your username/password.
And when you click Show error details:
TLS Negotiation failed, the certificate doesn't match the host., code: 0
This happens with accounts that have been working without problems and the issue started to appear 48 hours ago. At first errors happened every once in a while, but now with some accounts all sent emails bounce. It appears that other people are being affected as well: Outgoing email stopped working, error reported while recovering outgoing mail account

The issue happens in a GoDaddy EU while ASIA is working fine.
Image GoDaddy support just admitted that the issue is in their server(s) and asked to wait for 24 hours after which it should be working again
Apr. 10, 4:54 pm
Please check after 24 hrs
> So it is an issue in your server?
yes
> Email have not been working for 3 days...
you will not face any issue after 24 hrs
I am currently waiting for the 24 hours what GoDaddy asked. If they will not get their systems working by then, I will continue searching for fixes/workarounds and checking how widespread this issue really is. Meanwhile, I keep monitoring the situation.

Please let me know if the same is happening to you, too, and especially if you found a fix or a workaround. Thanks!



Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-10 18:46

Update: Some GoDaddy accounts in ASIA datacenter are also now malfunctioning, so this issue appears to be not limited to their EU datacenter, unless the problem is actually in gmail and GoDaddy support just lied to me earlier. That would not have been the first time...

rahul

Unread post by rahul » 2020-4-11 09:16

I have been facing the same issue for the last 48 hours and the issue doesn't seem to go away

Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-11 13:18

GoDaddy "award-winning support team" was again lying to me, so I wasted 24 hours by waiting for their "solution" instead of finding the fix by myself right away. Anyway, I found a permanent solution for the issue. It is easy, free and does not involve GoDaddy which means it can be done right away instead of waiting forever for nothing to happen. Here are the steps for fixing Gmail on GoDaddy.
  1. Login to your GoDaddy account
  2. Select All Products and Services
  3. Click Manage in Web hosting section Image
  4. Click cPanel Admin Image
  5. Copy the shared server host name from the cPanel URL. Host name is between https:// and :2083/ so in this example case the correct host name would be n3plcpnl0082.prod.ams3.secureserver.net Image
  6. Paste the host name to Gmail settings Accounts and Import/Send mail as/edit info/SMTP Server and click Save Changes
Image What made the issue more complicated was that both gmail and GoDaddy are to be blamed. Gmail has changed the way how they check SSL certificates and GoDaddy support is exploiting the issue by trying to peddle useless products for their clueless customers. Please let me know if you are still having issues after applying my fix.
Image
Happy hacking,

Santeri

jasonjsimon

Unread post by jasonjsimon » 2020-4-11 22:21

You are seriously a hero. I spent hours trying to find a workaround to this problem, and I'm tired of forking out to GoDaddy for everything they want to nickel and dime for. You buy the SSL package for a way overpriced amount and doesn't even cover the mail subdomain. They suck.
Anyway I am so grateful for this solution. You have helped me tremendously!!

Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-12 03:31

Happy to help. Please don't buy SSL certificates from GoDaddy. I wrote a script for having free, automatic SSL certificates on GoDaddy: Automatic Let's encrypt SSL on GoDaddy.

jasonjsimon

Unread post by jasonjsimon » 2020-4-12 05:20

Wow, you are amazing Santeri. I will not be resubscribing to Godaddy crap ssl service, thanks to you. Eventually I hope to move off them entirely. Have you found a good host you are really happy with?

Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-12 06:07

No, AFAIK they are all bad. I have been thinking about renting my own server as a solution. The email is the biggest issue with all hosting companies. None of them seem to know how to do it well or they are too greedy crippling their systems in order to make more money. The good thing with GoDaddy is that I know already their tricks and I know not to trust them, so that I can protect my customers from them and figure out solutions by myself to the issues they are creating.

Guest

Unread post by Guest » 2020-4-12 06:17

Same principle worked with a Crazy Domain url. Thanks for the pointer!

MozzyMagic2

Unread post by MozzyMagic2 » 2020-4-13 12:54

Yes, fantastic. This issue has been driving me crazy since it started recently. Thank you so much.

abhi_admin

Unread post by abhi_admin » 2020-4-13 16:01

try using domainname.com in you SMTP field
it worked for me

Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-13 16:25

try using domainname.com in you SMTP field
it worked for me
That works only if you have your own server with dedicated IP address and reverse DNS properly configured. Unfortunately that is not the case with shared hosting servers like GoDaddy's.

Guest

Unread post by Guest » 2020-4-13 22:45

Any other fixes for this. My worm email is through network solutions but I have it as an alias in gmail and not been able to use it for days.

I deleted it and re-added the account, but all it's done is give me about 1300 previously deleted emails in my inbox, but I still can't send anything.

Santeri
Posts: 311
Joined: 2017-7-5 09:58

Unread post by Santeri » 2020-4-14 03:14

Guest wrote:
2020-4-13 22:45
Any other fixes for this. My worm email is through network solutions but I have it as an alias in gmail and not been able to use it for days.

I deleted it and re-added the account, but all it's done is give me about 1300 previously deleted emails in my inbox, but I still can't send anything.
Adding and deleting accounts has no effect on this issue. You need to change the alias to the server name that is in the reverse DNS of your IP address. Do you have cPanel? If you have, what is the URL of your cPanel after you have logged in to it?

You're the best

Unread post by You're the best » 2020-4-14 04:09

It worked! This has been driving me nuts. You are a excellent person. Thank you.

mpnourian

Unread post by mpnourian » 2020-4-14 17:23

having the same problem as of yesterday April 13, and mt e mail are being bounced back with the same error: TLS Negotiation failed, the certificate doesn't match the host.

so far have not found a fix, and trying to reset or edit the sending e mail address did not work either.

phxutah

Unread post by phxutah » 2020-4-14 17:49

Thanks for the help! This worked perfectly!

stokeboner

Unread post by stokeboner » 2020-4-14 18:02

Yayy, this worked just had to change my smtp server. Its not just go daddy its gmail.

marchair@gmail.com

Unread post by marchair@gmail.com » 2020-4-14 19:23

Thanks, this got me on the right track to sorting the problem with my ISP.

Big thumbs up!

MPN

Unread post by MPN » 2020-4-14 19:40

for those of us who don;t have an account, can we create one and follow the steps to get the gmail deliver the mail sent through another email? :evil: